28 Kasım 2015 Cumartesi

Fglrx (AMD/ATI SAHİPLİ SÜRÜCÜSÜ) Kurulumu ve Gnome İle Çalışması için Muhakkak Yapılması Gerekenler

AMD firmasının web sitesindeki sürücü paketini kurabilmemiz için öncelikle dağıtımımızda aşağıdaki paketler kurululu olmalı:

gcc g++ make dkms fakeroot

Örnek olarak bu paketlerin Debian tabanlı sistemlerde kurulumu için Terminale girilecek komut:

 sudo apt-get install gcc g++ make dkms fakeroot

Daha sonra ilgili sürücü dosyasını aşağıdaki adresten indirmeliyiz:

 http://support.amd.com/en-us/download/desktop?os=Linux%20x86

Dosyayı indirip arşivi açtıktan sonra terminale (dosya adını sizdeki versiyona göre güncelleyeceksiniz):


 chmod +x radeon-crimson-15.11-15.30.1025.run

ve şimdi sürücünün kurulumuna başlayabiliriz:

 sudo ./radeon-crimson-15.11-15.30.1025.run

Kurulum sihirbazı çalıştı otomatik kurulumu seçip kuruluma devam ettik ve kurulum tamamlandı, bize yeniden başlatmak isteyip istemediğimizi sorduğunda hayır diyeceğiz.

Ters insanlar olduğumuz için değil masaüstümüzü tekrar görmeyi istediğimiz için yapacağız bunu.

Terminali açıp aşağıdaki komutu gireceğiz:

sudo aticonfig --initial

Masaüstümüzü tekrar görmeyi hala istiyor ve Gnome masaüstü ortamı kullanıyorsak:
Aşağıdaki adımları takip etmeliyiz.



SADECE GNOME KULLANICILARI İÇİN GEREKLİ:



Fglrx ile Gnome arasındaki sorunlar malumunuzdur. Öncelikle "GDM"ye OpenGL sürümümüzü tespit etmesi için yardım etmek üzere terminale şu komutları sırayla girelim:


su

echo "export COGL_DRIVER=gl" >> /etc/environment

echo "export COGL_OVERRIDE_GL_VERSION=1.4" >> /etc/environment

echo "export COGL_RENDERER=GLX" >> /etc/environment


echo "export LD_PRELOAD=/usr/lib/fglrx/fglrx-libGL.so.1.2" >> /etc/environment

Sonra da Gnome sessionumuza OpenGL sürümümüzü söyleyelim ki sorun çıkmasın. Bu sefer "Root" olmamamız gerekiyor yani önce exit yazıp ENTER tuşuna basacağız. Daha sonra aşağıdakı komutları terminale sırayla gireceğiz:

touch ~/.xsession

echo "export COGL_DRIVER=gl" > ~/.xsession

echo "export COGL_OVERRIDE_GL_VERSION=1.4" >> ~/.xsession

echo "export COGL_RENDERER=GLX" >> ~/.xsession

echo "export LD_PRELOAD=/usr/lib/fglrx/fglrx-libGL.so.1.2" >> ~/.xsession


echo "gnome-session" >> ~/.xsession

Artık bilgisayarımızı yeniden başlatabiliriz.

Önemli Not.

Xorg versiyonumuz en fazla 1.17 olmalı
Sürücü sadece Kernel versiyonu 3.19a kadar destekliyor
4 versiyonları patch yüklemelisiniz.

Sadece Gnome 3.14 ve 3.16 üzerinde deneyip çalıştığını gözlemleyebildim. 3.18 Hakkında bir fikrim yok.

Hiç yorum yok:

Yorum Gönder